You can only upgrade to Dynamicweb 9 from Dynamicweb 8.8.1.x Or later.

Please see our Upgrading to Dynamicweb 9 documentation for other requirements.